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What is Domain Name Portfolio Management?

Domain Portfolio Management is the process of  organizing, managing and monitoring 
all your Internet domain names. Domain names are a very important business asset 
that have to be protected. It is  also important to keep track of the various websites 
corresponding to the domains. Domain Name Portfolio Management makes it easy to 
do this and more from a single interface.

You can use any one of the following 3 products to manage your domain name portfolio.

1. Watch My Domains Professional (for basic domain name management, for 
individuals and small businesses)

2. Domain Punch Professional (advanced domain name management for 
businesses)

3. Watch My Domains ISP (more advanced domain name management with a 
database back-end and support for SQL queries. For large businesses, corporates 
and individuals with large domain name portfolio)

This guide primarily concentrates on Domain Punch Professional.

What can you do with Domain Punch Professional? 

1. List and categorize all your domain names

2. Automatically lookup and retrieve domain name records wherever possible.

3. Allow quick access to domain name records and other information like

A. Owner Information

B. Domain Contacts

C. Domain Creation, Last Update and Expiry Dates

D. IP Address of corresponding website

E. URL the domain points to (or redirects to)

F. Registrar information

G. Name server information

H. MX records associated with the domain
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I. Server Ping Times

J. Search Engine Indexing Related (Web Visibility) Information

K. Other Custom Information

4. Create alerts  on specified events, for example, approaching domain expiry, changes 
to domain records or corresponding website.

5. Attach custom notes to domain names.
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The basic screen layout

The software screen layout consists of three panels.  The top panel holds the domain 
names and various extracted information in a neat table. The lower panel has a set of 

two views within a tabbed interface. One holds the actual raw whois  data for the domain 
that is selected in the top panel, the other one is the detail view that displays all the 
data for the domain. You can manually edit the data within the detail view.

A left vertical panel displays various domain categories, a domain scratch pad and the 
lookup queue. Please note that the available features will vary from product to product. 
For example, there is no domain category tree in Watch My Domains  Professional. The 
panel sizes may be adjusted by using the mouse.

By default the domain category bar includes a number of pre-created domain groups. 
These groups are displayed in a tree format in the domain category bar. 
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Adding Domain Names

Adding or Importing Domain 
Names Manually

You can add names into Domain 
Punch Pro using the ribbon bar 
buttons for the purpose. You can 
manually type in the names or import 
names from a text file / older version 
DMS file.

While manually typing in the domain 
names, if you don't specify a domain 
extension (like com, net, etc.) the 
s o f t w a r e w i l l a d d e x t e n s i o n s 
automatically based on your top level 
domain list selection. You can edit the 
TLD list using the “Whois Config” 
option.

Enter only valid domain names

When entering domain names, make 
sure that you type in only valid top 
level domains. One common mistake 
is  entering URLs or typing in host 
names like www.softnik.com. The 
whois  lookup will return a "not found" 
message if you add invalid domain 
names.

Here are some examples of valid 
domain names.

1. softnik.net

2. softnik.com

3. software.biz

4. cats.info

5. cats.co.uk
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The following are not valid entries

1. www.softnik.com

2. www.business.info

3. blog.domain.de

Importing domain names 
from a text file or from the 
older DMS (v1) files.

The Import button allows you to 
import domain names from a text file 
or from DMS files used by the 
previous version of Domain Punch 
Pro.

Creating Domain Names in Domain Finder

Domain finder contains additional options for constructing domain names from 
keywords and character templates.
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Domain Names From Keywords

You can create domain names by merging two or more keywords. For example you can 
create domain names like computerworld.com, softwarebiz.com by merging words 
(computer & world, software & biz, etc). You can do this very easily using the "Finder > 
Add Domain Names > From Keywords" ribbon option. The keyword based domain 
builder supports up to 3 keywords that may be merged. You can type in the keywords 
into the three boxes. The software comes with a built in list of keywords (accessible 
using the Auto button).

Creating Domain Names from Templates

This  option ("Finder > Add Domain Names > From Templates" ribbon option) allows you 
to create domain names from alphabets and digits. For example if you wish to generate 
a list of all possible 3 character domain names made up of a-z, you just need to type in 
&&& and click Generate.

Internationalized Domain Names (IDN)

Domain Punch Professional supports IDN. This means  that you can manage domains 
that contain non-english (non-ascii) characters (see the screen shot below).
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To manage Internationalized Domain Names (IDN) you should first enable IDN support 
from the application settings dialog ("Config > App Settings"). If IDN support is enabled, 
the software will allow you to add non-ascii domain names.

When you do a whois or DNS lookup the software will automatically convert these into 
their Punycode format and then do the lookup.

Please note that other lookups like web visibility, trademark check etc. may not 
function properly for domain names in non English languages.
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Looking up Domains

Domain Punch Pro supports the normal port 43 whois lookups and DNS lookups (to find 

the IP address the domain points to). You can use one of the ribbon bar buttons within 
the Domain Whois group to start the lookups.

There are options to update only the domains that haven't been updated within a set 
time limit.

To quickly check the domain records of a small set of domains, simply highlight them, 
right click and select the menu item labeled “Whois Check Selected”.

Adjusting lookup speeds

The “Whois Config” button on the ribbon bar allows you to specify the minimum 
interval between two connections and the number of allowed simultaneous connections 
to a whois server. By default, for most whois servers the setting is  1 simultaneous 
connection. Adjusting these values will make the lookups faster or slower.
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Please be aware that high speed lookups are not a good idea. Please see the 
knowledge base article on whois lookup problems for details on this.

To prevent getting black listed by various registrars  we have set very conservative 
lookups speeds by default.

Simultaneous Connections

This  specifies  the total number of simultaneous connections that will be made to the 
whois  server by the software.  Set it to an optimum number based on your bandwidth, 
CPU resources and the connection count allowed by the registrar.  Please note that 
some whois servers will block access if you make too many simultaneous connections.  

Connection Interval

The software employs an interval timer to initiate new connections.  You can adjust the 
timer interval using this parameter.

If you find too may connection errors, come back to the connection settings  box and 
adjust these settings.

Query Limit at Various whois servers

Most registrars  have made changes to their whois servers to prevent very high speed 
whois  access.  It is  very important that you set the connection interval to higher value 
(15 seconds and above). Also make sure that the number of simultaneous connections 
is set to 1 or 2. 

If you continuously make a large number of requests, registrars may ban your IP 
address.
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Over-riding the whois connection settings

It is  possible to globally over-ride connection interval and connection count settings for 
all whois servers. This allows you to speed up the whois lookups whenever you want to 
do a small set of lookups. The over-ride is  applicable to the current software session. 
Please note that you should do this only if you know what you are doing.

DOMAIN PUNCH PROFESSIONAL
 
 USER GUIDE

PAGE 15 OF 42
 
 SOFTNIK TECHNOLOGIES



Configuring Whois Servers

Domain Punch Professional supports a large number of top level and country code 
domains. It also supports any domain extension that allows lookup through a port 43 
whois server. So if your country code is not supported, you can easily add support for it.

Most of the whois server options for a specific domain can be accessed by right clicking 
on a domain in your domain list and selecting the options under the Whois Setup 

popup menu.

See screen shot above.

Number of simultaneous "Max Connections"

This  specifies the total number of connections that are made from your system to whois 
servers. Some whois servers impose a limit on number of simultaneous connections 
that are allowed.  If you find that connections  are being refused, decrease this number 
to a lower value.
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Connection Interval

Specifies the gap between two sets of connections.  Increase this if you get too many 
errors.

Tip: When you have a large number of domains in the database the software may 
become slow and sluggish whenever multiple lookups are in progress. Increase the 
connection interval to a large number if this happens.

It is  possible to temporarily override the whois  connection settings. Please refer to the 
end of previous section for details.

Adding Support for new Country Code Domains

To configure support for any top level or country code domain you will need to know

• The port 43 whois server for the domain

• A unique string in the whois output that indicates the availability or non availability of 
a domain for registration

• Any additional query options (specified by the whois server operator)

To configure various top level and country codes you should use the

Domain Manager > Setup > Whois Config

ribbon bar option. This will list all the currently configured top level and country code 
extensions. 

To add a new domain extension, simply type in the extension into the box (at the lower 
part of the window) and click the Add button. Then select the new extension in the list 
and click the Settings... button.

Essential Whois Server Setup

The "essential settings" allows you to configure the basic whois server information.

Normally the query prefix box should be left blank. However for Com and Net domains 
the proper query prefix is “domain” and is required.

The query prefix is useful for whois servers  that require special options. For example, to 
manage German domain names with umlauts, the following query prefix is required.

-T dn -C ISO-8859-1

Please visit the registrar web sites for details on similar options supported by different 
whois servers.
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You can also change the port used for doing whois lookups (from the default port 43). 
Use this only if you have special access to whois servers on a different port (eg: 
Nominet DAC). 

Domain Availability String Token

The search token is a unique string in the whois output that indicates  the availability of a 
domain for registration. This will be a string like “Not found”, “No Match”, etc. However 
there are cases where the whois output indicates the reverse. For example, a whois 
output may show “Not available” when a domain is already registered. In such cases 
you can put a ~ before the string to indicate that the domain is  available when the string 

is not present.

Resetting changes made to whois configuration

If you make changes and the software stops working properly you can reset the 
changes for a specific domain extension by removing all entries  for that TLD. You may 
also contact us for support. Please see the last section of this user guide for contact 
information.
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Advanced Whois Server Configuration

You can use the Whois Server Settings button to access the advanced configuration 
dialog. This allows you to specify the connection interval, number of simultaneous 
connections, etc. for a whois server. Please see “whois usage restrictions” to see why 
this is important.

To increase the speed of lookups you should increase the number of allowed 
simultaneous connections and decrease the connection interval.

For TLDs and ccTLDs that have multiple registrars (eg: COM, NET domains) the 
connection intervals and connection count need to be set separately for each whois 
server. The easiest way to do this is by right clicking a domain and selecting the 
"Whois Setup > Advanced Whois Settings..." menu. This is required because you will 
not be able to access the settings for all the whois servers from the original “Whois 
Config” option.

Most whois output have standard header and footer messages that may be removed for 
a better on screen display. You can specify string tokens for cleaning the whois output.

Advanced String Tokens For Data Extraction

There are times when simple string token settings will not work. Here are a couple of 
advanced string extraction token examples.

[Zone-C]@@Name:

German domain records have multiple blocks of data each with same text tokens. The 
above will allow you to extract the “Registrar Name” (look for the token “Name:” that 
follows “[Zone-C]” in the whois records).

Registrant:@@#L#2

Some whois records may always contain the required data at a specific line number. 
Use the above to pick the text at line 2 after the occurrence of the token 
“Registrant:” (please note that blank lines are ignored).
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Web Based (http, port 80) Whois

It is possible to make Domain Punch professional retrieve whois records from a web 
based (http) script.

Assume that your whois lookup page is at

http://www.yourdomain.com/whois?domain=example.com

You should enter the following in the whois setup dialog.

Whois Server: www.yourdomain.com
Port: 80
Comand Line: GET /whois?domain={D}

Please fill in the other settings like date format, search token, etc. based on the actual 
whois record data as returned by your script.

This will not work if the web based script uses authentication or a CAPTCHA input.

Why would you need http based whois?

If you have a special agreement with any registrar for access to their whois API, you can 
create your own (PHP/Python/any other) whois script and upload it to your server. Then 
use that script instead of accessing the port 43 whois server.
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Whois Usage Restrictions

Software like Watch My Domains (Pro and ISP) and Domain Punch Professional 
retrieves domain records by connecting to various whois servers. These whois servers 
are operated by the registry and/or various domain registrars.  

Because of the large number of Whois lookups that are being done, most registrars 
have set limits on how the whois servers  could be accessed.  It is very important that 
these terms and conditions are understood and followed whenever you use a software 
that performs whois lookups.

Unfortunately there is no uniform set of rules followed by each registrar. Each and every 
registrar has their own set of rules (and some times these are not even mentioned any 
where) 

Problems with too many unrestricted lookups

If you do too many whois lookups you will soon start seeing outputs similar to the 
following

Welcome to the NSI Registrar Whois Server.

Your IP address is  contained within a list of IP addresses that may have failed to abide 
by Network Solutions' Whois policy.

If you feel this is in error, please contact us at ....

Here are some examples of the limits set by different domain registrars. Please note 
that these are just a few examples. Almost all registrars have similar limits in place.

Tucows (whois.opensrs.net) rejects multiple simultaneous connections from the same 
IP. You will have to be satisfied with one connection at a time.

BulkRegister (whois.bulkregister.net) will immediately block the IP temporarily if they 
notice a large number of connections being made. This is done by their software 
automatically.

Network Solutions (whois.networksolutions.com) will block the IP temporarily if you do 
more than 1000 lookups in a day.

Go Daddy (whois.godaddy.com) will simply start hiding all the relevant information from 
the returned whois text if your IP gets in their list.

Nominet (UK domains) has a published whois usage policy available at their site. 

...most other registrars also have similar restrictions.
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Doing Whois Lookups, the right way

All our domain name management software products allow you to configure the number 
of simultaneous connections and a connection interval. This will ensure that you don't 
abuse the whois servers and get banned. The ideal setting in software like Watch My 
Domains is  1 connection and a lookup interval of 12 seconds or more (5 connections 
per minute).

If you find your IP address being banned permanently, the only solution is to contact the 
registrar and discuss the problem with them. 

If your internet connection has a permanent IP, you should be very careful while using 
any software that connects to whois servers. Make sure that your IP doesn't find its way 
into the registrar ban lists  because of excessive usage. If you ever find your IP banned 
give them a call and explain your situation. Find out what got you banned and assure 
them that you will follow their whois policy usage guidelines.
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Domain Whois Lookups Not Working?

Do you have problems when looking up domains that are registered through certain 
registrars? This could happen because of the following reasons.

All domain name lookup software including Domain Name Analyzer, Domain Punch 
Pro, Watch My Domains (Pro & ISP), etc. require access to port 43. You will need to 
enable access to this port if you are behind a firewall or proxy. So ensure that the whois 
lookup problem is not because of a blocked port 43 before reading further.

Most of our software is highly configurable. For example, it is possible to change the 
port used for lookups  to another port (instead of 43). So be aware of any changes  you 
have made to the software configuration.

The registrar's whois server is temporarily down.

Solution: Please wait a while and try again. Check your registrar's website to see if 
there is a prior announcement of a down-time.

There is a network problem at your ISP or some where else.

Solution: You should wait a while before retrying, contact your ISP or your network 
administrator.

The whois connection to the server is timing out

Solution: Increase the time out interval for whois connections. By default this is 18 
seconds. You might want to increase it to say 30 or in some cases 90 seconds. Use the 
Edit > DNS & Whois Lookup Settings menu option to do this.

The registrar's whois server is blocking connections from your 
computer.

Solution:Please see the section on whois usage restrictions. If your IP is being blocked 
you should stop all lookups immediately. Most registrars  reset their ban list every 24 
hours. So if you keep redoing the lookups your IP may be banned for longer duration.

You can also use the diagnostic whois  tool to check if the port 43 connections  from your 
IP address are being blocked.

The registrar's whois server is blocking connections from your 
ISP.
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Solution: This  is a common issue with UK domain lookups and is  more troublesome 
because both the ISP and the registrar will deny there is a problem. In some cases you 
might just have to use another ISP.

You have a firewall / proxy server setting that is preventing 
connections to the registrar's whois server.

Solution: Make sure that you have enabled connections through port 43 and that you 
are not blocking connections to certain addresses. Contact your network administrator 
in case you don't control the firewall or proxy.

You have a software configuration / setup error

Solution: Make sure that you have specified the proper whois servers, connection 
settings etc. within the software. Mostly this  is done from the Edit > Top Level Domain 
List menu option.

Please double or triple check the entries. Spelling errors in the whois server name are 
difficult to notice at times.

You can reset the whois setup for any TLD/ccTLD by right clicking on a domain name 
in the list and selecting Data Extraction Setup > Reset To Default menu option.
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Domain Categories

Domain Punch Professional allows  you to categorize domains  into various groups or 
categories. By default it also includes a number of pre-created domain groups. These 
groups are displayed in a tree format in the domain category pane.

You can use the Manager > Views > Categories ribbon option to toggle the domain 
category tree on or off.

To add additional groups to the Manually Grouped List within the domain tree simply 
right click on the tree and use the Add New Category menu option. See the screen shot 
below.

To add domains to a group you should right click on a domain name in the main list and 
select Categorize Selection. Highlight multiple domains (using the ctrl or shift key along 
with mouse click) and then use the Categorize Selection option to group multiple 
domains.
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Renaming Domain Category Names

Domain categories can be renamed by clicking on the name of the category twice (once 
to select the category and then a second time to start the in-place editing. Don't double 
click!)

Domain Category Editor

An easier way to manage the domain categories is  through the domain category 
editor. Access this by right clicking within the domain category tree.

You can easily move domains in and out of various categories from within the editor.
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Domain Alerts, Web-scripts and more...

Domain Alerts

The Domain Alerts option allows you to setup various alerts and automated options 
within the software. These include...

1. Expiry date highlight - Sets the number of days  (ahead of expiry date) to turn the 
on-screen display highlight on.

2. Email Alert - Sends an email to the specified address when a domain name record 
is  changed. You will need to specify the SMTP server and the email addresses. 
Simple SMTP authentication is also supported. However, some SMTP servers may 
fail to work due to various spam protection protocols. In such cases please use the 
Web Script method. You may also try using one of the MX servers of the email 
domain as the SMTP server. The MX server will normally accept emails meant for 
domains it manages.

3. Web Script - Software can be made to execute a specified web based script when 
a domain record is altered. The information about the changes is passed as a 
POST variable to the script. You need to name the POST variable (see screen shot 
below). Use this  method if you are unable to use the Email (some ISPs may not 
allow Emails). 

4. Auto Lookups - Turn automatic lookups on/off and specify the lookup intervals.

Domain Record Change Logs

The data record change log is  automatically 
generated and appended to the log whenever 
you do a lookup. You can access  the log file 
from the “View Tab > Domain Log” ribbon 
button.
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Sample PHP Web Script

Here is a sample PHP script you can use to send domain name alerts. Please replace 
the names and email addresses appropriately and then upload the script to your server. 
Then type in the URL of the script in the above settings dialog.

The script uses 'alerts' as the POSt variable name. You can change it and specify the 
same variable name in the software settings box.
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<?php
if( isset($_POST['alerts'])) 
{

 $notes     = $_POST["alerts"];

 $notes     = stripslashes($notes);

 $notes     = strip_tags($notes);

 $subject   = "Domain Name Alert";

 $fromname  = "Your From Name";

 $fromemail = "from@example.com";


 $toname    = "Your To Name";

 $toemail   = "to@example.com";



 $to   = $toname.' <'.$toemail.'>';

 $from = 'From: ' . $fromname . ' <' . $fromemail;

 $from .= ">\r\nReturn-Path:" . $fromemail;



 mail($to, $subject, $notes, $from);

 echo "Done";
}
else
{

 echo "Error";
}
?>

mailto:from@example.com
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Simple Website Monitoring - Automatically 
Monitor Domain Home Pages and Check For 
Specified Text Tokens

Domain Punch Professional will allow you to do simple website monitoring. You can 
specify text tokens to look for in the home pages of each of your domains. If the 
specified text token is not found, it will be indicated in the domain display list. The 
software can also trigger an alert and execute a pre-assigned webpage script if the text 
token is not found.

Use this to automatically monitor if all your domain names are pointing to the proper 
web pages.

Specify The "String To Search For" For Each Domain

The string to look for in the web pages are specified in a column / field called Home 
Page Token. You can edit the Home Page Tokens using the detail tab (see the 
screenshot below). You can also "bulk add" or import the search texts (see below for 
instructions).

The "Page Token Found" Column
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This  value will be unset (value=0) if the string specified in "Home Page Token" is not 
found in the domain home page HTML. By default this value is always set.

Enable the display of "Page Token Found" Column

You can enable the display of Page Token Found column by right clicking within the 
domain list and enabling it from the Setup Columns options.

Redirected Domains

If you are redirecting the domain home page, you can specify a string from the redirect 
URL as the token. Please see the screen shot above. Since the domain is being 
redirected to softnik.info/parked.php, the home page token is set to "softnik.info/
parked.php"

Please note that the software will not be able to find the search text if it is in the final 
redirected web page.

Domain Alert if the Search Token is Not Found

If you have enabled domain alerts  for HTTP lookups, an alert will be generated 
whenever the domain home page doesn't contain the specified search token. You can 
then optionally execute a web page script.
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Adding HTTP Search Tokens in Bulk

You can select multiple domains (using Shift / Ctrl Key and mouse click) and then 
specify the same Home Page Tokens for all the selected domains by right clicking 
within the list and selecting "More Lookups > Add Http Search Tokens"

Importing HTTP Search String Tokens From a CSV File

You can import the Home Page Tokens from a CSV (Comma Separated Value) file by 
right clicking within the list and selecting "More Lookups > Import Http Search Token"

The first (header) row in the CSV file should be the following...

Domain,Home Page Token

Each row after the header should be the domain name followed by a comma and then 
the search text. You can wrap the search text string within quotes  if it also contains a 
comma.

Here is a sample CSV file.

Domain,Home Page Token

domainpunch.com,"Domain Portfolio Management"

softnik.co.uk,"softnik.info/parked.php"
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Web Page Redirect Monitoring

The home page lookup (http) options provide a powerful method to monitor where your 
websites point to. Use it to find

• The HTTP status code returned by the domain’s home page on the web

• The redirect URL (if the home page redirects to another location)

• The title of the web page (<title> tag contents)

• IP address (A record)

Domain MX Record / Mail Server Monitoring

You can use Domain Punch Professional to check if all your domains have been 
properly configured to send / receive emails.

You can display the MX records as  host names (MX1, MX2… columns) or IP addresses 
(MXIP1, MXIP2… columns). Right click within the domain list and select “Setup 
Columns” to enable the display of required columns.
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Lookup Queue and On-screen Legends

Domain Punch Professional performs different types of lookups for obtaining 
information. These include whois lookups (normally on port 43), Http lookups (port 80), 
Ping checks, DNS Lookups, etc. The lookup status  is indicated through a cryptic 
message on the status bar and through a lookup queue list (may be toggled on/off using 
the Manager > View > Lookup Queue ribbon option.

Lookup Queue

When lookups are in progress, the status bar displays the queue status. For an 
explanation of the cryptic status bar display, please see the screen shot on the right.

In addition to the status bar display, the View > Lookup Queue Bar menu option will 
allow you to see the domain names that are in queue.
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Problems when extracting Expiry Dates

Different registrars use different formats for expiry dates, last updated dates, etc. 
Domain Punch Professional is capable of finding the correct format automatically. 
However in certain cases the software will not be successful.

For example, if it encounters  a date like 08-11-2012, there is  no way to know which is 
the date and which is  the month. In such cases Domain Punch will not extract the date. 
But it is capable of learning the format as it encounters more domain name records  from 
the same registrar. For example, if it notices another domain name record with the date 
03-31-2011, it will know that the registrar uses mm-dd-yyyy format. From then on, the 
software will extract the dates for that registrar without any problems.

If the expiry date/creation date is inaccurate or is missing...

We have tried to make the software support as  many whois  servers as possible.  In 
some cases we may not have considered a particular whois server or the output format 
may have changed.  Simply contact us with the domain names that do not work.  In 
most cases we will be able to suggest a simple configuration change that will solve the 
problem. If this is not possible, we will fix it as soon as we can.

In some cases, the expiry date may not be present at all in the port 43 whois data 
record supplied by the registry / registrar. In such cases there is no other option other 
than manually entering it using the details view.

DOMAIN PUNCH PROFESSIONAL
 
 USER GUIDE

PAGE 34 OF 42
 
 SOFTNIK TECHNOLOGIES



Manually Entering / Editing Data

There are times when you need to manually enter data into the domain list. For 
example, some registrars do not provide the expiry dates in their port 43 whois records. 
In such cases  you can manually add the expiry date and then lock the data so that it is 
not overwritten accidentally.

To manually edit the domain records, use the Details View.

Domain Details (Property) View

The details view (easily accessible in the lower panel of the software window) allows 

you to quickly view and edit the data corresponding to domain.

Write Protecting Manually Edited Domain Data

Whenever you manually edit or enter a data for a domain, the entire recordset for that 
domain is  automatically write protected. This will prevent the manually entered data 
from being overwritten due to a whois lookup.

Identifying modified and or write-protected domain records
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Write protected domains will display a [] around the index number for the domain (the 
"#" column). A ~ in the "# column" indicates  that the domain record was manually 
altered.

Write protected domains will not be looked up again. So you will need to unset the 
write protect status to re-enable whois  lookups for that domain. You can do this by 
right clicking the domain in the main list and selecting the appropriate option or not 
enabling the write-protect check box in the details tab.
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Web Forms Manager - Quick Access To Domain 
Registrar & Hosting Accounts

What is Web Forms Manager?

Web Forms Manager is a tool for quickly logging into your registrar management 
account, web hosting interface or any other on-line resource. 

Some setup is required for this.

You need to know the POST URL and the POST data variable names. If you have some 
knowledge of HTML you can quickly inspect the HTML source of the web page in 
question and create a compatible setting within Domain Punch Pro or Watch My 
Domains ISP.

How To Access Web Forms Manager?

To access the Web Forms Manager, right click on any domain and select "Web Forms 
Manager" from the menu. By highlighting a domain before invoking the Web Forms 
Manager, you will have access to any of the record values for that domain as a 
parameter in the POST data.
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For example, If you highlight softnik.com and invoke the Web Forms Manager, you can 
use {Domain} as an entry in the POST data. The software will automatically replace 
{Domain} with softnik.com. If you use {Registry Expiry} as a POST data, it will be 
replaced with the actual registry expiry date when the web form is invoked.

See the list under the Allowed Merge Fields list to see all the allowed merge 
parameters.

Adding Your own Merge Fields

You can add custom merge fields  to the list. These appear within a pair of [] and can be 
used within the POST data.

Here is an example setting for Tucows.

URL: https://manage.opensrs.net/index

Post Data:
reg_domain={domain}
reg_username=[Tucows Login]
reg_password=[Tucows Password]
action=login

You need to add two custom merge Fields called Tucows Login and Tucows 
Password (and set the values to your actual login name and password) to use the 
above settings.

Limitations and a Warning!

The Web Forms manager will not work on sites that use extensive Java script or use 
complicated session management. It will also not work if your registry settings have 
been changed to prevent access to Internet Explorer through the Windows shell API.

Please don’t setup your actual login names and passwords in computers that are 
not secure. If you do it anyone can run Domain Punch Pro on that computer to access 
your domain registrar account!

Checking the POST Data

You can quickly check if the POST variables are being posted properly by creating a 
simple PHP script containing the following one line entry.

<?php print_r($_POST); ?>

Upload it to your server and change the URL in the Web Forms Manager to your test 
URL. Click the Run button and your script will display all the POST data values. Use it 
to find problems with the settings in Web Forms Manager.
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Saving, Loading Files, Copying and Exporting Data

Domain Punch Professional v2 saves the documents as projects.  You can save the 
entire data to different projects and load them again using the "Project > Save" and 
"Project > Open" menu options.

Each project consists of multiple files. So the software creates a directory for each one. 
You can specify a data store path which will become the root directory where all 
projects are stored.

It is best if you set the data store path just once. If you keep changing the data store 
path the software will end up creating projects  at multiple locations  and you will not be 
able to open the projects easily.

Backing up your work

By default the data store path is "My Documents/Domain Punch Professional v2/"

So simply backup the above location (or wherever you have set the data store path to) 
whenever you want to archive your data.
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Copying Data to Clipboard

The Output ribbon tab has options for copying the data to the clipboard or to files on 
disk. Options for copying to the clipboard are also available by right clicking within the 
domain data table.

Exporting / Printing Data

The output ribbon tab lists  several options for exporting the data from the domain table. 
You can also print the domain table. Make sure that you adjust the column widths 
properly before printing (use the print preview while adjusting the column widths).

Backup Whois Settings

To backup the whois configuration used by Domain Punch Professional, use 
RegEdit and export the following key.

HKEY_CURRENT_USER\Software\Softnik Technologies\Whois Setup v2

You can do this from command-line using some thing like the following

regedit /e “C:\Users\Home User\Documents\whoisbackup.reg” “HKEY_CURRENT_USER\Software
\Softnik Technologies\Whois Setup v2″

The above will export the whois settings key branch to a file called whoisbackup.reg in 
the directory specified. Remember to specify the file path for the “.reg” file properly.
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Diagnostic Port 43 Whois Tool

All our domain name software tools include a diagnostic port 43 whois lookup tool 
available from the Config Tab > Popup Whois ribbon button (Tools > Popup Whois 

Tool menu in earlier versions). You can use this to quickly lookup a domain name or 
check if port 43 connections are working properly.

To check a domain name type in the whois server and the domain name into the 
appropriate boxes and then click 'Go'.

In some cases you can use the whois tool to determine the valid whois server for a 
country or top level domain by querying whois.iana.org. For example to find the whois 
server for query whois.iana.org for it. Now look through the whois output and you will 
find the whois server listed as “Whois Server (port 43): whois.nic.it”.
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Getting Additional Help / Support

You can get additional support by contacting us or checking our blog. 

Blog URL
http://www.softnik.com/blog/

Contact Us
http://www.softnik.com/icenter/contact.php

Domain Punch Professional Software Updates
http://www.domainpunch.com/products/domainpunch/changelog.php

SEO Lab Professional

Advanced Competition Research, Keyword Idea Brainstorming and Marketing Software 
Suite for SEO Specialists. Available for Windows and Mac OS X.

http://www.seolab.com/
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